Instability in control panel login
Incident Report for Acendy
Resolved
The login service is now back in normal operation.
Posted Oct 30, 2024 - 18:07 CET
Investigating
Some customers are experiencing some trouble loging in to our control panel.

Tip: If you have trouble logging in, try to log in via incognito mode in your browser.
Posted Oct 28, 2024 - 11:46 CET
This incident affected: Control panel.